BUGS 2.7 KB
*********************************
* KNOWN BUGS / MISSING FEATURES *
*********************************

* pck-update plugin
 [security] evaluation of `%define' directives could lead to security issues
            (the problem exists in the rpm itself)
 [bug]      '/usr/share/linuxdoc-tools/dist/linuxdoc-tools/info/mapping'
            should not be considered an info page
            hint: grep '/info/' is a broken test; the `file' tool cannot be used
                  because info pages are compressed
 [bug]      Il seguente comando:
               autospec -u bbpress -a1,5,10
            causa l'errore:
               ERROR: pacchetto non trovato:
               `/usr/src/RPM/RPMS/noarch/%sitename-website-}bbpress-0.8.2.1-2mamba.noarch.rpm'
            in fase di upload.
            Causa: parsing non corretto della riga (se "sitename" non è definito?)
               Name:          %{?sitename:%sitename-website-}bbpress
 [feature]  action 8, test 4
            should check if `/usr/lib/libpopt.so' --> `libpopt.so.0.0.0' is a valid link
            should display a warning on broken symlinks
 [feature]  support the gpg signatures of rpm packages

* libspec
 [feature]  specfile.getvars(): missing implementation for `%ifarch' and `%ifdef'
 [feature]  add support for commands like:
               %{expand:%%define kernel_minor_version %(echo %version | cut -d. -f3)}

               example: lilo.spec
               %{!?latex_doc: %define latex_doc 1}
                  DEBUG: resolve_rpmvars: conditional block (%if) [level#1]  --  %if %latex_doc
                  DEBUG: resolve_boolexpr: boolean expression [ %latex_doc ]
                  DEBUG: resolve_boolexpr: expanding boolexpr using: name (lilo)
                  DEBUG: resolve_boolexpr: expanding boolexpr using: version (22.7)
                  DEBUG: resolve_boolexpr: boolexpr nullified -- [ %latex_doc ]
                  DEBUG: resolve_boolexpr: set: $1 = "%latex_doc", $2 = "", $3 = ""
                  expr: sintax error

               example nagios.spec
               %{!?EMBPERL: %define EMBPERL 0}
                  DEBUG: : set: $1 = "%{EMBPERL}", $2 = "", $3 = ""
                  expr: sintax error

* spec-create plugin
 [feature]  check for non standard (/usr/lib) library files path

* documentation
 [feature]  missing english translation of `autospec.1' and `autospec-it-HOWTO'.
            *** NEED EXTERNAL HELP ***

******************
* IMPORTANT NOTE *
******************

Have you found a bug not listed above?
Please post a description and possibly a way to reproduce the bug to
  <davide.madrisan(a)gmail.com>

If you're feeling especially nice, you should make a patch to fix the flaw.
Sending patches as attachments is preferred, but not required.